soula81
5 years ago5,000+ Views
4 comments
Suggested
Recent
maaan. though I still use it.
It's mostly true for Internet Explorer 9 and below. Windows 8 and IE 10 are fine :p
can any tech guy here let me know if this is true? lol
Hahaha, too true. Brilliant. Luckily for those "special" people we have tools to help them help themselves. :p
11
4
3